以下配置仅供程序正常使用,不具备性能测试标准。

服务器要求 单节点部署

  • CPU:双核(2C) 四线程(4T) 主频2.0GHz+
  • 内存:32G+
  • 磁盘:1T+
  • 基础环境:JDK 1.8+
应用说明
应用名 必装 应用类型 建议内存 最小内存
MySQL 5.6+ 外部 2G 1G
RabbitMQ 3.5+ 外部 2G 1G
Redis 3.0+ 外部 16G 8G
FastDFS 5.11 外部 1024M 512M
Skywalking[1] 6.0+ 外部 1024M 512M
Filebeat[2] 6.8+ 外部 256M 128M
Logstash[2] 6.8+ 外部 8G 2G
ElasticSearch[1][2] 6.8+ 外部 16G 8G
Kibana[2] 6.8+ 外部 1024M 512M
Apollo 1.5+ 外部 1024M 512M
OpenOffice 外部 512M 256M
Nginx 外部 1024M 512M
Consul[3] 1.2+ 外部 1024M 512M
Eureka[3] IBPS 1024M 512M
Zuul IBPS 1024M 512M
Oauth2server IBPS 2G 1G
Platform IBPS 2G 1G
Business[4] IBPS 2G 1G

注:

  • [1] : Skywalking、ElasticSearch,链路监控功能支持,版本必须匹配;
  • [2] : Filebeat、Logstash、ElasticSearch、Kibana,日志监控/分析功能支持,版本必须一致;
  • [3] : Consul、Eureka,服务发现功能支持,二选一,部署包创建时决定;
  • [4] : Business,业务服务,对应自己的业务服务,如OA服务、ERP服务,需要业务服务支持表单、流程功能在开发阶段添加对应依赖即可;
  • 如果使用链路监控功能,就必须有足够大的内存去支撑ElasticSearch存储;
  • 如果使用日志监控/分析功能,就必须有足够大的内存去支撑ElasticSearch存储;
  • 必装应用内存总和30G,系统运行也需要内存所以推荐服务器内存32G
文档更新时间: 2020-05-08 14:49   作者:Eddy